Problema
Su alcuni sistemi macOS, non è possibile aprire lo Steinberg Download Assistant oppure all'apertura, viene visualizzata la rotella che gira, senza alcuna opzione per accedere all'applicazione.
Causa
Questo errore potrebbe essere causato dall'utilizzo di un carattere (font) corrotto per un nome dell'applicazione.
Soluzione
Innanzitutto, è necessario eseguire un backup dei caratteri (font) di macOS per poter eventualmente reinstallare quelli non standard in un secondo momento, nel caso in cui la soluzione fornita non sia risolutiva.
Per fare ciò, andare nella cartella /Sistema/Libreria/, fare clic con il pulsante destro del mouse sulla cartella contenuta "Fonts" e selezionare "Comprimi 'Fonts'" dal menu contestuale. Questo creerà un file .zip contenente la cartella "Fonts" di backup.
A questo punto, si potrà procedere con il ripristino dei caratteri originariamente inclusi in macOS utilizzando il "Font Book". Una descrizione della procedura è disponibile nelle pagine del supporto Apple. Assicurarsi di avere selezionato la versione corretta del sistema operativo, poiché i passaggi per raggiungere questo obiettivo potrebbero essere diversi.
Se lo Steinberg Download Assistant si avvierà con il set di caratteri macOS standard, significa che è stato installato almeno un carattere che non funziona correttamente. Per capire di quale carattere (font) si tratti, nel caso in cui fosse necessario restringere ulteriormente il campo, si potrebbero reinstallare i caratteri aggiuntivi uno per uno dal file di backup della cartella compressa, fino alla ricomparsa dell'errore.